PCワークマンロゴ
  • トップページ
  • サービス内容について
  • saibisu 作業価格工賃・について
  • ご依頼・申込み方法
  • 修理工房案内・地図
  • パソコン修理・改造ブログ
  • お問合せ・お見積りメールフォーム

記事一覧

Windows2000 Server 起動しない

ファイルサーバーで使っている Dell/PowerEdge700 を再起動させたら立ち上がらなくなったので見て欲しいという、いつもお世話になっている市内の法人さんからの案件。

かなり古いDellのエントリーサーバーだが、まだこの年代のサーバー機を使っている法人さんも結構あるのではないだろうか。
CドライブにシステムとしてSeagateのSATA/40GB。Dドライブを共有データ領域としてMaxtorのSATA/120GBをRAID無しで運用している環境。

両HDD共にSMARTエラーを出しているのでかなり厳しい状態かも・・
とりあえずシステムドライブの修復から作業すると、まあ、ひどい状態だった。
190セクターもクラッシュして、1000以上のセクターが読み出し遅延状態(クラッシュ寸前)に陥っていた。

ファイル 106-1.jpg

もしこれで起動したら、その方が奇跡的だ。
ActiveDirectory等も使用していない、純粋なファイルサーバーとしての環境なのでシステムはHDD交換後にOSを再インストールした。

問題は共有データドライブだが、OSがこの状態では、おそらく正常にデータの書き込みが出来ている訳がないだろう。
データドライブも、やはりクラッシュが確認できたが、セクター修復作業後に速攻でイメージを取る。この時点で、ほぼすべてのファイルが生きているのを確認済みなので安心して復旧作業が出来る。

とりあえず2000Server側からスキャンディスクを掛けてみるが、ファイルテーブルの不整合が多発していて、スキャンディスクはものすごい状態に。

ファイル 106-2.jpg

スナップは瞬間の画像だが、ブレているのではなく、前に表示されていたテキストの残像が写っている。
Matrixみたい。汗
なかなか見応えがあったが♪結果、違う方法でデータ復旧を行った。
一部のデータは消失したが、99%はデータ復旧出来たのではないだろうか。

話を聞くと、10年近くサーバーメンテナンスはしていないと言う・・。
(導入してから一度も・・です)
この程度の被害で済んで、不幸中の幸いですね。滝汗

いまさら PentiumIII-S ですか?・・・

今の時代では使っている人は居ないであろうと思われる Epson Type-PD 一体型PC。
「まだまだ動かしたい」と思っている方も一部には居らっしゃるようだ。

オリジナルはSocket370 / Celeron1.1A GHzのTualatin-256コア。
(何故か1.3Aではなかった・・・?)
これをTualatin最速のPentiumIII-S/1.4GHzに換装する。
PentiumIIIはものすごいバリエーションがあるので分かりにくい。
今回換装して取り付けるPentiumIIIはSL6BYになる。
チップセットはSiS630ST。CPUはCeleronなのでFSBが100MHzに設定されている。

PentiumIII-S/1.4GHzはFSB133MHz×10.5で動作する為、FSBを変更しなければ正常には動作しない。
このままでは約1GHz(1050MHz)の動作になってしまう。

だが、この時代のM/Bには、ちゃんとFSB切り替え用のDIPスイッチが付いている。
今の時代のBIOSの様に自動で合わせてくれる事は無く、すべてが手動である。

ファイル 105-1.jpg

ただ、メーカー製PCの場合はM/B上に切り替えパターンのプリントが無い為、自分で試行錯誤して、設定パターンを見つけなければならない。

デフォルト設定では1番S/WだけがONの状態で100MHzに設定される。
試しに2番もONにしてみると133MHzに設定されるようだ。
起動してみると無事に1.4GHzで認識・起動した。

ファイル 105-2.jpg ファイル 105-3.jpg

だが、BIOSからはEBの河童/133MHzで認識されている様だ・・BIOS未対応?いまさら。
でもWindowsからは正常に認識されてるし、まあ、安定して動けばいいか~。♪
意外とテキトーです。

メモリーをMAXの512MBに増設して、HDDを120GBのモノに交換し、WindowsXP/Proの英語版をインストール。
やはりTualatinはサクサク動く・・が、やはり動画系はもう厳しい。
オンボードのVGAではCPU使用率が100%で張り付いたままになってしまう。

このPC、実は海外の英語圏途上国で使われる予定なのです。
向こうでは、まだこの程度のPCでも結構需要があるという事。
日本の「もったいない」精神が海外でも生きているのは良いことですね。ハート

Windows7 64bit SRTSPL64.SYS エラー

Windows7 Professional 64bitで起こった 0x00000050 のブルースクリーンエラー。
滅多にお目にかかれないだろう? Dell Precision Workstation M6500 で起きたトラブルである。ただし、このエラーは特に機種依存するものではない。

ファイル 104-1.jpg

メモリかHDDのトラブルっぽいが、実はSymantecのアプリケーション、主にNortonなどアンチウィルス系のアプリがクラッシュして起きるようだ。

今回はSymantec Endpoint Protectionという法人向け総合セキュリティソフトがクラッシュして引き起こしたトラブルだ。

症状の切り分けとしては、セーフモードで起動し、シマンテック系のサービスとスタートアッププログラムをOFFにして再起動してみれば良い。ただ、他にもシステムファイルがクラッシュしている可能性が大きいので、修復は必須となる。

それにしてもこのノートPCデカすぎる・・。B4サイズ?
スケッチブックサイズPCだ。♪
ACアダプターも19.5V/12.3Aと200W超クラスの電源。弁当箱サイズの大きさ。ドクロ

ファイル 104-2.jpg

弁当箱だといろんな大きさがあるが、3.5インチHDDよりデカイのはご覧のとおり。!

Advanced Format Technology AFTの罠

通の方ならご存知だとは思うが、AFTとはWesternDigitalが最初に発売した4KiB(4096バイト)物理セクター採用のHDDに実装された512Byte論理セクターのエミュレーション技術の事である。

AF対応HDDはOS側から見ると、あたかも今までの512バイトセクターのHDDのように振る舞ってくれて?意識せずに苦労もなく使うことができるが、XPではアライメントがずれて速さが出ないなどトラブルも多い。

そろそろ「この手」のトラブルが来るかな・・
と以前から思っていたら自分でも全く気が付かなくてハマった。

少し古めのPanasonic/CF-Y8のリカバリーが出来ないという案件。
XPのダウングレード権が付いたVistaとXP、2つのOSがインストール可能なお得なPCだ。
昔はこういうモデルがあったねえ。懐かしい。

Vistaにリカバリーしようとしても、最後に「Windowsを構成できませんでした」というエラーでリカバリーが終了してしまう。
(スナップ撮りませんでした^^;)

何度かエラーを出されて、やっと気がついた。^^;
あ~、この時代に2.5インチの1TB/HDDなんて有るわけ無いだろう・・。
外してみれば写真の通りWDのAFT対応の4KセクターHDD/WD10TPVTだった。

ファイル 103-2.jpg ファイル 103-1.jpg

リカバリーの時に問題になるのは、国内メーカー製PCのリカバリーディスクは工場出荷時のイメージファイルをNortonのGhostなどを使って圧縮/展開してインストールするモノが多いという事。

調べてみると、WesternDigitalのホームページに「クローンイメージのリカバリーはリカバリー後にユーティリティを使ってアライメント調整をしろ」と書かれている。
Vista / Win7のクローンイメージでもアライメントがズレるようですね。

まあ、それは置いておいて、今回はリカバリーイメージ内に含まれているIntel Matrix Storage Managerがエラーを出していたのが原因。
Matrix ManagerがAFTに対応していないのは有名な話なので、多くは語りませんが・・。

試しにクリーンインストール後にMatrix Managerを入れてみたら(インストールは出来るのです。不思議。)WindowsUpdateはすべて0x800系エラーで失敗する。
Security Essentialsもエラーが出てインストール不可。・・これじゃあダメだね。汗

なかなか気が付かず、お恥ずかしい話だが、みなさんも気をつけましょう・ね♪

CMOS電池ホルダー交換 / ケースSW交換

なんて事はない修理作業だが、こんな地道な修理もやってます。

写真はECSのM/Bで、お客様がご自分でCR2032ボタン電池を交換しようとして、固定の爪を割ってしまった。
良くありそうなトラブル?交換前と交換後のスナップ。

ファイル 102-1.jpg ファイル 102-2.jpg

次は「電源が入らない」と持ち込まれたショップブランドのBTOパソコン。
電源ユニット不良だろう・・
と思い、試しに本体スイッチを入れてみると「手応え」がない。
「ふにゃ」っとした感じである。電源を入れた手応えがない・・という表現が適切かも?

ファイル 102-3.jpg ファイル 102-4.jpg

テスターで検査すると、明らかに導通がなくケース側S/Wの接触不良。
途中で切断して新品と交換して終了。無事電源が入る様になった。

今回は、またまた写真整理の投稿でした。汗